overlay/dev-python/black/black-20.8_beta1.ebuild
2022-03-24 12:06:13 +01:00

29 lines
534 B
Bash

# Copyright 2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3+ )
inherit distutils-r1
MY_PV="${PV//_beta/b}"
MY_P="${PN}-${MY_PV}"
DESCRIPTION="The Uncompromising Code Formatter"
HOMEPAGE="https://github.com/psf/black"
SRC_URI="https://github.com/psf/${PN}/archive/${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
S="${WORKDIR}/${MY_P}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="*"
BDEPEND="dev-python/setuptools"
PATCHES=(
"${FILESDIR}/black-20.8_beta1-setuptools_scm.patch"
)